Queue backlog!
Incident Report for Subeta
Resolved
We finished our upgrade successfully and are bringing the site back up! We will be monitoring to make sure it continues to work. Thank you for your patience!
Posted Jan 21, 2020 - 17:20 EST
Investigating
We're currently investigating this issue! Please rest assured that all of your item data is safe. Just got a little overloaded with connections, so we're doing a quick upgrade. We'll be back online soon!
Posted Jan 21, 2020 - 17:15 EST
This incident affected: Subeta.net.