Extreme Lag
Incident Report for Subeta
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 17:25 EDT
Identified
We've identified the issue as our cache instance, and are working to replace it
Posted Jun 21, 2020 - 18:07 EDT
Investigating
We are currently investigating this issue.
Posted Jun 21, 2020 - 18:04 EDT
This incident affected: Subeta.net.