Site down for maintenance!
Incident Report for Subeta
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 16:20 EST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2020 - 16:19 EST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2020 - 16:19 EST
Investigating
We're doing some quick maintenance to address lag on the forums, should be no more than 15 min.
Posted Feb 19, 2020 - 16:18 EST
This incident affected: Subeta.net.