Major Server Problems
Incident Report for Subeta
Resolved
We've made some changes and have brought the site up again. We are keeping an eye on the server status.
Posted 10 months ago. Oct 13, 2017 - 19:34 EDT
Monitoring
We are aware of and investigating the issues with servers and lag.
Posted 10 months ago. Oct 13, 2017 - 18:31 EDT