Shoutbox
Incident Report for Subeta
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 18, 2017 - 23:16 EDT
Investigating
We are currently investing the live problems with the shoutbox. We do not currently have an ETA on when this will be fixed. Thank you for your patience.
Posted about 1 year ago. Jul 18, 2017 - 15:25 EDT